BCH Data Delay in Reactor and KYT

Incident Report for Chainalysis

Resolved

This incident has been resolved.

Reactor data is current, and transfers are processed without delays in KYT.

If you encounter further delays with BCH, please reach out to support@chainalysis.com
Posted May 12, 2026 - 11:50 UTC

Investigating

BCH is currently experiencing data delays in Reactor and KYT. We are investigating the issue and will share more information as it becomes available.

Please reach out to support@chainalysis.com for any questions.

Next update at 14:00 UTC
Posted May 12, 2026 - 10:06 UTC
This incident affected: Crypto Investigations (Reactor) and Crypto Compliance (KYT UI).