KYT API Indexing Error for Bitcoin processing

Incident Report for Chainalysis

Resolved

This incident is now resolved.
We will be correcting transactions with wrong output addresses in the coming days. No action is needed from customers.
If you have any questions, please let us know at support@chainalysis.com
Posted Apr 11, 2025 - 00:56 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 10, 2025 - 21:12 UTC

Monitoring

A fix has been implemented, and we will continue monitoring for further disruption.

If you have any issues, please reach out to support@chainalysis.com
Posted Apr 10, 2025 - 16:02 UTC

Identified

The team are confident they have identified the issue and are now working on confirming this and implementing a fix.

We will share more details once we have more information.

Next update at 17:00 UTC
Posted Apr 10, 2025 - 11:56 UTC

Update

We are still verifying that the fix is working and investigating the root cause of this issue.

Next update at 13:00 UTC on April 10th.
Posted Apr 10, 2025 - 00:55 UTC

Update

We are still verifying that the fix is working and investigating the root cause of this issue.

Next update at 01:00 UTC on April 10th.
Posted Apr 09, 2025 - 22:04 UTC

Update

We have implemented a fix which we believe will mitigate the issue, but we are still investigating the root cause. Once we verify the fix is working, we will begin updating any transactions that had the incorrect output_address.

Next update at 22:00 UTC.
Posted Apr 09, 2025 - 19:13 UTC

Investigating

We are receiving reports that the output_address returned in the KYT API does not match the expected output_address based on the submitted index for some Bitcoin transfers. We are still investigating the root cause.

No action is required from customers at this time.

Next update at 22:00 UTC.
Posted Apr 09, 2025 - 18:28 UTC
This incident affected: Crypto Compliance (Transfers API (KYT API)).