Polygon Mainnet stall at block height 74,592,238

Incident Report for Chainalysis

Resolved

This incident has been resolved.

If you require further assistance, please reach out to support@chainalysis.com
Posted Jul 30, 2025 - 19:02 UTC

Identified

We have been alerted to an ongoing issue with the Polygon Mainnet; it's stalled at block height 74,592,238. This is affecting all Polygon network operations. Customers should expect that this will impact interactions with Polygon with Chainalysis products such as Reactor and KYT.

This is out of the control of the Chainalysis team. We are monitoring the situation. Customers can follow the StatusPage for Polygon here: https://status.quicknode.com/incidents/cjqf5klxfbdh

We will continue to monitor the situation and provide updates as we get them.
Posted Jul 30, 2025 - 12:22 UTC
This incident affected: Crypto Compliance (KYT API, Entities, KYT UI) and Crypto Investigations (Reactor, Stories, Investigations API, Rapid Lookup).