Kryptos Data Delay
Incident Report for Chainalysis
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 16:49 UTC
Identified
We have identified an issue causing a delay in Kryptos benchmarking data.

We are working on a fix for this issue and will keep you updated when this is in place.
Posted Nov 18, 2022 - 18:34 UTC