Error in opening users in KYT
Incident Report for Chainalysis
Resolved
This incident has been resolved. Please contact support@chainalysis.com if you have any questions or need any further assistance.
Posted May 16, 2024 - 09:48 UTC
Investigating
We have been notified that customers are receiving errors when opening user profiles in KYT and are investigating the issue. We will share more information when it becomes available.

Next update at 10:00 UTC
Posted May 16, 2024 - 08:17 UTC