KYT UI Unavailable
Incident Report for Chainalysis
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 14:00 UTC
Monitoring
We experienced a brief service disruption with KYT UI between 19:00 - 19:30 UTC.

The issue is currently resolved. We are monitoring actively.
Posted Jul 25, 2024 - 19:44 UTC
This incident affected: Crypto Compliance (Transaction Monitoring).